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Access Tutorial 1: Introduction to M

 purpose of these tutorials is not to teach you 
rosoft Access, but rather to teach you some 
eric information systems concepts and skills 
g Access. Of course, as a side effect, you will 
n a great deal about the software—enough to 
e your own useful applications. However, keep in 
d that Access is an enormously complex, nearly-
strial-strength software development environ-
t. The material here only scrapes the surface of 
ess development and database programming.

Introduction: What is Access?
rosoft Access is a relational database manage-
t system (DBMS). At the most basic level, a 
S is a program that facilitates the storage and 

eval of structured information on a computer’s 
 drive. Examples of well-know industrial-strength 

tional DBMSes include
Oracle

• Micro
• IBM D
• Inform

Well-kno
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• Micro
• Borla
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ocedural programming personality expects 
 view your application as commands to be 
ted sequentially;
ject-oriented personality expects you to 

your application as objects which encapsu-
tate and behavior information.

t makes no effort to provide an overall logi-
ation of these personalities (indeed, it is 
hat such an integration is possible). Instead, 
 you as a developer to pick and choose the 
roach to implementing your application.

re are often several vastly different ways to 
nt a particular feature in Access, recogniz-
ifferent personalities and exploiting the best 
(and avoiding the pitfalls) of each are impor-
 for Access developers.

ntage of these multiple personalities is that 
ible to use Access to learn about an enor-
ge of information systems concepts without 
 Introduction to Microsoft Access

• a full-featured procedural programming lan-
guage —essentially a subset of Visual Basic,

• a simplified procedural macro language  unique 
to Access;

• a rapid application development environment  
complete with visual form and report develop-
ment tools;

• a sprinkling of objected-oriented extensions ; 
and,

• various wizards and builders  to make develop-
ment easier.

r new users, these “multiple personalities” can be 
source of enormous frustration. The problem is 
at each personality is based on a different set of 
sumptions and a different view of computing. For 
stance,
• the relational database personality expects you 

to view your application as sets of data;

• the pr
you to
execu

• the ob
view 
late s
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s and Visual Basic programs for extending 
nctionality of database applications.

 database objects are stored in a single file 
filename>.mdb . When you are running 
a temporary “locking” file named <file-

b  is also created. You can safely ignore 
file; everything of value is in the *.mdb file.

arning objectives
w do I get started?

w do I determine the version I am using?

w do I create or edit a database object?

hat is the database window and what does 
contain?

w do I import an Excel spreadsheet?

w do I delete or rename database objects?
 Introduction to Microsoft Access

ving to interact with a large number of “single-per-
nality” tools, for example:

• Oracle for relational databases
• PowerBuilder for rapid applications development,
• SmallTalk for object-oriented programming.

ep this advantage in mind as we switch back and 
rth between personalities and different computing 
radigms.

1.2 What is in an Access database 
file?

though the term “database” typically refers to a col-
ction of related data tables, an Access database 
cludes more than just data. In addition to tables, an 
cess database file contains several different types 

 database objects :
saved queries for organizing data,
forms for interacting with the data on screen,
reports for printing results,

• macro
the fu

All these
named <
Access, 
name>.ld

the *.ldb 
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rom the main menu to see which version 
sing.

l the screen shots in these tutorials are 
ken from Access version 7.0 (released as 
rt of Office 95). Although there are some 
portant differences between version 2.0 
d version 7.0, the concepts covered here 
e the same for both. Version 8.0 (released 
 part of Office 97) is only slightly different 
m version 7.0. 

henever the instructions given in the tutorial 
ffer significantly from version 7.0, a warning 
x such as this is used.

reating a new database
 the directions in Figure 1.1 to create a 
atabase file called myfile.mdb . 
 Introduction to Microsoft Access

� How do I get help from the on-line help 
system?

� How do I compact a database to save space?

3 Tutorial exercises
 this tutorial, you will start by creating a new data-
se file. 

3.1 Starting Access
• To start Access, you double click the Access icon 

(  for version 8.0 and 7.0 or  for version 
2.0) from within Microsoft Windows.

you are working in the Commerce PC Lab, you will 
 working with Access version 2.0. If you are work-

g at home, you will able be to tell what version you 
e using by watching the screen “splash” as the pro-
am loads. Alternatively, select Help > About 

Access f
you are u
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r new (empty) database. 

database by selecting File > 
main menu or by clicking the 
” button on the tool bar.

 database name and press Enter. 
are limited to 8-letter names in 
 Introduction to Microsoft Access

FIGURE 1.1: Select the name and location of you

Create a new 
New from the 
“new database

�

Type in a new
Note that you 
version 2.0.

�
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you are using version 8.0, you can use 
ther univ0_v2.mdb  or univ0_v7.mdb  for 
e tutorials. When you open the file, Access 
ll ask you if you want to convert it to version 
0. Select yes and provide a new name for 
e converted file (e.g., univ0_v8.mdb )

 the univ0_v x.mdb  file and examine the 
nts of the Sections  table, as shown in 
e 1.3.

mporting data from other 
applications

akes it easy to import data from other 
ns. In this section, you will create a new 
g data from an Excel spreadsheet.

t File > Get External Data > Import from the 
menu and import the depts.xls  spread-
 Introduction to Microsoft Access

• Examine the main features of the database win-
dow—including the tabs for viewing the different 
database objects—as shown in Figure 1.2. 

3.3 Opening an existing database
nce an empty database file is not particularly inter-
ting, you are provided with an existing database 
 containing information about university courses. 
r the remainder of this tutorial, we will use a file 
lled univ0_v7.mdb , which is available from the 
torial’s Internet site.

If you are using version 2.0, you will need to 
use the univ0_v2.mdb  database instead. 
Although you can open a version 2.0 data-
base with version 7.0, you cannot open a ver-
sion 7.0 database with version 2.0. Importing 
and exporting across versions is possible, 
however.
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se objects  for a particular application.

The database window is always 
available from the Window menu.

re 
g 

Macros — are sets of high-
level commands that can be 
used to process data and 
perform repetitive tasks.

Modules — 
contain Visual 
Basic 
procedures and 
functions.
 Introduction to Microsoft Access

FIGURE 1.2: The database window  contains all the databa

Tables —
contain data 
in rows and 
columns.

Queries — allow the 
information in 
tables to be sorted, 
filtered, and shown 
in different ways. Forms — are for 

displaying 
information on 
the screen.

Reports —a
for organizin
and printing 
information.
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 Access that you are using and then 
le

 Database 
nu.

You can open a 
database object for 
viewing, for 
modification, or 
create a new object.
 Introduction to Microsoft Access

FIGURE 1.3: Open the univ0_vx.mdb  file for the version of
open the Sections  tab

Select File > Open
from the main me�

Select the 
correct file and 
open the 
Sections  
table.

�



Tutorial exercises1.

NextHome Previous 9  o f  17

etting help
trend in commercial software (especially 
rosoft) is a reliance on on-line help and doc-
on in lieu of printed manuals. As a conse-
a good understanding of how to use the on-
system is essential for learning any new 
. In this section, you will use Access’ on-line 
em to tell you how to compact a database.
 F1 to invoke the on-line help system. Find 
ation on compacting a database, as shown 

ure 1.6. 
iarize yourself with the basic elements of 
lp window as shown in Figure 1.7. 

ompacting your database
 the directions provided by the on-line help 
w shown in Figure 1.7 to compact your 
ase.
 Introduction to Microsoft Access

sheet as a new table called Departments  (see 
Figure 1.4). 

In version 2.0, the menu structure is slightly 
different. As such, you must use File > Import.

• Use the import wizard specify the basic import 
parameters. You should accept all the defaults 
provided by the wizard except for those shown in 
Figure 1.5.

• Double click the Departments  table to ensure it 
was imported correctly. 

If you make a mistake, you can rename or 
delete a table (or any database object in the 
database window) by selecting it and right-
clicking (pressing the right mouse button 
once).
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�
Select files of type *.xls  (files 
with that extension will show in 
the file window).

�

Double-click depts.xls .�

a table called Departments .
 Introduction to Microsoft Access

Select File > Get External Data > 
Import from the from the main menu 
and move the directory containing the 
file you want to import.

FIGURE 1.4: Import the dept.xls  spreadsheet as 



Tutorial exercises1.

NextHome Previous 11  o f  17

 to import the Excel file.

Select the first row contains 
column headings option so 
that the column headings in the 
spreadsheet are not interpreted 
as data.

�

Since we have not talked 
about primary keys yet, 
select no primary key.

�

 Introduction to Microsoft Access

FIGURE 1.5: Use the spreadsheet import wizard
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IGURE 1.6: Use the help system to find 
information on a specific topic

atch from 
pacting 
ouble-
f topics.

Double click the most 
promising entry in this list 
to get the actual help topic.

�

For most students, the help 
system in Access version 
2.0 is easier to navigate. 
Use the “cue cards” in 
version 2.0 to get step-by-
step instructions for many 
operations.
 Introduction to Microsoft Access

FType in the first few 
letters of the topic you 
are looking for.

�

Select the best m
the list (i.e., “com
databases”) and d
click to get a list o

�

The Index is the best place to 
start when you are looking for a 
specific topic. If you need more 
structured information or are 
looking for an overview, use the 
Contents tab.
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 to compact your database

Press help topics to return to the 
index.

Minimize (rather than close) help 
when you are working so that you can 
use the Back button to return to 
previously visited topics without 
repeating the search.

Words underlined with a dashed line 
provide important definitions.
 Introduction to Microsoft Access

FIGURE 1.7: Follow the instructions provided by help



Discussion1.

NextHome Previous 14  o f  17

1.

1.
Th
in
da
sin
in
re

In
tio
in
di
st
en

Ac
“o
sin

ompacting a database
lp system points out, Access database files 
me highly fragmented and grow to become 
ger than you might expect given the amount 
ey contain (e.g., multiple megabytes for a 
f records). Compacting the database from 

me eliminates fragmentation and can dra-
 reduce the disk space requirement of your 
.

enaming a database
 the case that you are working with a data-
 want to save it under a different name or 
 to a different disk drive. However, one 

d on the File menu that is conspicuous by its 
 is Save As. 

, when compacting your database, Access 
the name and destination of the compacted 
 result, the compact database utility can be 
 Introduction to Microsoft Access

4 Discussion

4.1 The database file in Access
e term “database” means different things depend-

g on the DBMS used. For example in dBase IV, a 
tabase is a file (<filename>.dbf ) containing a 
gle table. Forms and reports are also stored as 

dividual files with different extensions. The net 
sult is a clutter of files.

 contrast, an Oracle database has virtually no rela-
nship to individual files or individual projects. For 

stance, a database may contain many tables from 
fferent projects/applications and may also be 
ored split into one or more files (perhaps on differ-
t machines).

cess strikes a convenient balance—all the 
bjects” (tables, queries, forms, reports, etc.) for a 
gle project/application are stored in a single file.
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sequence for prototyping using Access is 
ing:

l the information of interest in terms of enti-
nd relationships between the entities (this is 
ed in the lecture portion of the course).
e a table for each entity (Tutorial 2).
ify the relationships between the tables 
rial 3).
ize the information in your tables using 
s (Tutorial 4, Tutorial 5, Tutorial 10)

e forms and reports to support input and 
t transactions (Tutorial 6, Tutorial 7).
nce you forms with input controls 
rial 8)
e action queries (Tutorial 11), macros 
rial 13), or Visual Basic programs 
rial 12, Tutorial 14) to perform the transac-
rocessing functions of the application.
 Introduction to Microsoft Access

ed as a substitute for the Save As command. This 
especially useful in situations in which you cannot 
e the operating system to rename a file (e.g., 
en you do not have access to the Windows file 

anager).

4.4 Developing applications in Access
 general, there are two basic approaches to devel-
ing information systems:

• in-depth systems analysis, design, and imple-
mentation,

• rapid prototyping (in which analysis, design, and 
implementation are done iteratively)

cess provides a number of features (such as 
aphical design tools, wizards, and a high-level 
acro language) that facilitate rapid prototyping. 
nce you are going to build a small system and 
ce time is limited, you will use a rapid prototyping 
proach to build your application. The recom-

mended 
the follow

1. Mode
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, update the links to the data file, and the 
is done.

 not used linked tables in the assignment. 
e links are dependent on the absolute 

rectory structure. As a result, if the directory 
ructure on your machine is different from 
at on the marker’s machine, the marker will 
t be able to use your application without 

st updating the links (a time consuming pro-
ss for a large number of assignments).

pplication to the assignment
pleting this tutorial you should be ready to 

e database file that you will use for the 
r of the course.

e an empty database file called <your 

ID>.mdb . Remember that your group 
er consists of eight digits.
 Introduction to Microsoft Access

Create “triggers” (procedures attached to events) 
to automate certain repetitive tasks (Tutorial 15).

4.5 Use of linked tables
ost professional Access developers do not put their 
bles in the same database file as their queries, 
rms, reports, and so on. The reason for this is sim-
e: keep the application’s data and interface sepa-
te.

cess allows you to use the “linked table” feature to 
k two database files: one containing all the tables 
ata”) and another containing all the interface and 

gic elements of the application (“interface”). The 
ked tables from the data file show up in the inter-
ce file with little arrows (indicating that they are not 
tually stored in the interface file).

 this way, you can modify or update the interface 
 without affecting the actual data in any way. You 

st copy the new interface file over to the user’s 

machine
upgrade 
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2.

3.
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Import the inventor.xls  spreadsheet as your 
Products  table.
Use the compact utility to make a backup copy of 
your database (use a different name such as 
backup.mdb ).
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