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ables

arning objectives
w do I enter and edit data in the datasheet 
w of a table?

w do I create a new table?

w do I set the primary key for a table?

w do I specify field properties such as the 
put mask and caption?

hy won’t an autonumber field restart 
unting at one?

hat are the different types of keys?

torial exercises
torial, you will learn to interact with existing 
d design new tables.
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Access Tutorial 2: T

Introduction: The importance 
of good table design

les are where data in a database is stored; con-
uently, tables form the core of any database 
lication. In addition to basic data, Access permits 
rge amount of domain knowledge (such as cap-
s, default values, constraints, etc.) to be stored at 
table level.

Extra time spent thinking about table design 
can result in enormous time savings during 
later stages of the project. Non-trivial changes 
to tables and relationships become increas-
ingly difficult as the application grows in size 
and complexity.
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2.

2.
In
sk
co

ecturers, department heads, departmental 
es, and so on.
n to the database window and create a new 
as shown in Figure 2.3.
 table design window  shown in Figure 2.4, 
n the following information:  

t File > Save from the main menu (or press 
ol-S) and save the table under the name 
oyees .

ame Data type Description 
(optional)

eID Text use employee 
S.I.N.

Text First name

Text Last name

Text

Currency
 Tables

3.1 Datasheet basics
• If you have not already done so, open the 

univ0_v x.mdb  database file from Tutorial 1.
• Open the Departments  table. The important 

elements of the datasheet  view are shown in 
Figure 2.1. 

• Use the field selectors to adjust the width of the 
DeptName field as shown in Figure 2.1.

• Add the Biology department (BIOL) to the table, 
as shown in Figure 2.2.

• Delete the “Basket Weaving” record by clicking 
on its record selector  and pressing the Delete 
key.

3.2 Creating a new table
 this section you will create and save a very basic 
eleton for table called Employees . This table 
uld be used to keep track of university employees 

such as l
secretari

• Retur
table 

• In the
type i

• Selec
Contr
Empl

Field n

Employe

FName

LName

Phone

Salary
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epartments  table.

The asterisk (*) indicates a 
place holder for a new record.

esize the DeptName column by clicking near 
e column border and dragging the border to 
e right.
 Tables

FIGURE 2.1: The datasheet view of the D

The field names are shown in the “field 
selectors” across the top of the columns.

The records are shown as rows.

The grey boxes are “record selectors”.

The black triangle indicates the 
“current record”.

The “navigation buttons” at the bottom of the window 
indicate the current record number and allow you to go 
directly to the first, previous, next, last, or new record.

You can temporarily sort the records 
in a particular order by right-clicking 
any of the field selectors.

R
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rd to the table.

It is seldom necessary to 
explicitly save new 
records (or changes to 
existing records) since 
Access automatically 
saves whenever you 
move to another record, 
close the table, quit 
Access, etc.
 Tables

FIGURE 2.2: Adding and saving a reco

Add a new record by clicking in the DeptCode  field 
of the “new record” field (marked by the asterisk).�

To permanently save the change to the 
data, click on the record selector (note the 
icon changes from a pencil to a triangle).

�
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table.
 Tables

FIGURE 2.3: Create a new 

Click the New button to 
create a new table.�

Select “design view” (avoid using 
the table wizard at this point).�
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roperties for the Employees  table.
 Tables

FIGURE 2.4: Use the table design window to enter the field p

The “description” column allows 
you to enter a short comment 
about the field (this information 
is not processed in any way by 
Access).

Enter the field names and 
data types for the five fields.�

The “field properties” section 
allows you to enter information 
about the field and constraints on 
the values for the field.



Tutorial exercises2.

NextHome Previous 7  o f  18

2.
Ta
id
na
yo

2.
In
pr
Fi

RE 2.6: Set the field properties for the 
EmployeeID  field.
 Tables

3.3 Specifying the primary key
bles normally have a primary key that uniquely 

entifies the records in the table. When you desig-
te a field as the primary key, Access will not allow 
u to enter duplicate values into the field.

• Follow the steps in Figure 2.5 to set the primary 
key of the table to EmployeeID . 

3.4 Setting field properties
 this section, you will specify a number of field 
operties for the EmployeeID  field, as shown in 
gure 2.6.
• Since we are going to use the employees’ Social 

Insurance Number (S.I.N.) to uniquely identify 
them, set the Field Size property to 11 characters 
(9 for numbers and 2 for separating spaces)

• Set the Input Mask property to the following:
000\ 000\ 000;0

• Set the Caption property to Employee ID

FIGU
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Employees  table.

Click on the grey box beside the field (or 
fields) that form the primary key.

 in the tool bar or 
he menu.

To select more than one field for use as the 
primary key, hold down the Control key 
while clicking on the grey boxes.
 Tables

FIGURE 2.5: Set the primary key for the 

�

Either click the key-shaped icon
select Edit > Primary Key from t�
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 small dots ( ) to invoke the input mask 
d.

 the instructions provided by the wizard as 
n in Figure 2.8. 
 F1 while the cursor is still in the input mask 
rty. Scroll down the help window to find the 
ing of the “0”, “9”, “>” and “L” input mask 
ols.

iscussion

ey terminology 
one or more fields that uniquely determine 
ity of the real-world object that the record is 
 represent. For example, there is a record in 
nt information system that contains infor-
bout you as a student. To ensure that the 
 associated with you and only you, it con-
 Tables

• Select View > Datasheet from the main menu to 
switch to datasheet mode as shown in Figure 2.7. 
Enter your own S.I.N. and observe the effect of 
the input mask and caption on the EmployeeID  
field. 
Select View > Table Design from the main menu 
to return to design mode.
Set the field properties for FName and LName 
(note that Length and Caption are the only two 
properties that are relevant for these two fields)

3.5 Using the input mask wizard
 this section, you will use the input mask wizard to 
eate a complex input mask for a standard field 
pe. You will also use the help system to learn more 
out the meaning of the symbols used to create 

put masks.
• Select the Phone  field, move the cursor to the 

input mask property, and click the button with 

three
wizar

• Follow
show

• Press
prope
mean
symb

2.4 D

2.4.1 K
A key is 
the ident
meant to
the stude
mation a
record is



Discussion2.

NextHome Previous 10  o f  18

 properties on the behavior of the 
 entry

rovide a relatively easy way to 
asic data input errors without 
 complex error checking 
e, however, that it is possible to 
 a field so that users are unable to 
e values.

ss the Escape key when you are 
e to clear the changes to the record.
 Tables

FIGURE 2.7: Observe the effect of the input mask and caption
EmployeeID  field during data

If a caption is specified, it replaces the 
field name in the field selector.

Note that the input mask will not let you 
type any characters other than numbers 
from 0-9. In addition, the spaces between 
the groups of numbers are added 
automatically.

Input masks p
avoid certain b
having to write
programs. Not
over-constrain
enter legitimat

Try entering various characters and 
numbers into the EmployeeID  
field.

�
Pre
don�
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eate an input mask.

�

�

Since the input mask controls how 
the information in the field looks, it 
is possible to save some disk space 
by storing the data without the 
extras symbols, spaces, etc. For the 
size of system we are building, 
however, this savings is negligible.
 Tables

FIGURE 2.8: Use the input mask wizard to cr

Select “phone 
number” from the 
list of commonly-
used field types.

In Step 2, you may 
edit the input mask 
(e.g., remove the 
area code section).

The items in this 
list depend on the 
“international 
settings” specified 
for Windows (e.g., 
“Zip Code” may 
show instead of 
“Postal Code”).
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2.

 key is made by joining together two or 
 fields. Course numbers at UBC provide a 
example of a concatenated key made by 
g together two fields: DeptCode  and 
um. For example, department alone cannot 
 primary key since there are many courses 
h department (e.g., COMM 335, COMM 

 Similarly, course number cannot be used as 
 since there are many courses with the 
 number in different departments (e.g., 
M 335, HIST 335, MATH 335). However, 
tment and course number together form a 
tenated key (there is only one COMM 335).

gn key : In a one-to-many relationship, a 
n key is a field (or fields) in the “child” 
d that uniquely identifies the correct “parent” 
d. For example, DeptCode  and CrsNum in 
ections  table are foreign keys since these 
eys taken together are the primary key of 
 Tables

ins a field called “student number” that is guaran-
ed to be unique.

e advantage of using student number as a key 
stead of some other field—like “student name”—is 
at there may be more than one person with the 
me first and last name. The combination of stu-
nt name and address is probably unique (it is 
probable that two people with the same name will 
 the same address) but using these two fields as a 
y would be cumbersome.

nce the terminology of keys can be confusing, the 
portant terms are summarized below.

Primary key  — The terms “key” and “primary 
key” are often used interchangeably. Since there 
may be more than one candidate  key for an 
application, the designer has to select one: this is 
the primary key.
Concatenated key : The verb “concatenate” 
means to join together in a series. A concate-

nated
more
good 
joinin
CrsN

be the
in eac
391).
a key
same
COM
depar
conca

3. Forei
foreig
recor
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n, you can use the comment field in the 
ign window to document the meaning of 
es.

is strongly recommended that you avoid all 
n-alphanumeric characters whenever you 
me a field or database object. Although 
cess will permit you to use names such as 
stomer# , non-alphanumeric characters 

uch as #, /, $, %, ~, @, etc.) may cause 
documented problems later on.

Data types 

's data type tells Access how to handle the 
on in the field. For instance, if the data type 

e, then Access can perform date/time 
c on information stored in the field. If the 
te is stored as text, however, Access treats 
 any other string of characters. Normally, 
 Tables

the Courses  table. Foreign keys are identified in 
Access by creating relationships (see Tutorial 3).

4.2 Fields and field properties 

4.2.1 Field names 

cess places relatively few restrictions on field 
mes and thus it is possible to create long, descrip-
e names for your fields. The problem is that you 
ve to type these field names when building que-
s, macros, and programs. As such, a balance 
ould be struck between readability and ease of 

ping. You are advised to use short-but-descriptive 
ld names with no spaces.

r example, in Section 2.3.2 you created a field 
th name FName. However, you can use the caption 
operty to provide a longer, more descriptive label 
ch as First name . The net result is a field name 
at is easy to type when programming and a field 
ption that is easy to read when the data is viewed. 

In additio
table des
field nam

It 
no
na
Ac
Cu

(s
un

2.4.2.2

The field
informati
is date/tim
arithmeti
same da
it just like
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2.

e as a primary key when no other key is 
ed or is immediately obvious.

nce an autonumber is really Long Integer 
d since relationships can only be created 
tween fields with the same data type, it is 
portant to remember that if an autonumber 
used on the “one” side of a relationship, a 
ng integer must be used for the “many” side.

“Disappearing” numbers in 
autonumber fields

 the process of testing your application, you 
delete records from a table with an auto-
ey, you will notice that the deleted keys are 

imed.

nce, if you add records to your Customer  
suming that CustID  is an autonumber), you 
 a series of CustID  values: 1, 2, 3… If you 
 Tables

e choice of data type is straightforward. However, 
e following guidelines should be kept in mind:

Do not use a numeric  data type unless you are 
going to treat the field as a number (i.e., perform 
mathematical operations on it). For instance, you 
might be tempted to store a person's student 
number as an integer. However, if the student 
number starts with a zero, then the first digit is 
dropped and you have to coerce Access into dis-
playing it. Similarly, a UBC course number (e.g., 
335) might be considered a number; however, 
since courses like 439B have to accommodated, 
a numeric data type for the course number field is 
clearly inappropriate.
Access provides a special data type called Auto 
Number  (Counter  in version 2.0). An autonum-
ber/counter is really a number of type Long Inte-
ger  that gets incremented by Access every time 
a new record is added. As such, it is convenient 

for us
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number k
not recla

For insta
table (as
will have



Discussion2.

NextHome Previous 15  o f  18

la
yo

Cl
be
wo
in
to
cu

O
it,
yo
yo

difference whether the first customer in your 
rs table is CustID  = 1 or 534.

Input masks

mask is a means of restricting what the user 
 into the field. It provides a “template” which 
ss what kind of information should be in 
ce. For example, the input mask >LLLL  
of two parts:

ight brace > ensures that every character 
er types is converted into upper case. 
 if the user types comm, it is automatically 
rted to COMM.
haracters LLLL  are place holders for letters 
A to Z with blank spaces not allowed. What 
eans is that the user has to type in exactly 
tters. If she types in fewer than four or 

 a character that is not within the A to Z 
 (e.g., &, 7, %), Access will display an error 
age.
 Tables

ter delete customer 1 and 2, you will notice that 
ur list of customers now starts at 3.

early, it would be impossible for Access to renum-
r all the customers so the list started at 1. What 
uld happen, for instance, to all the printed 

voices with CustID  = 2 on them? Would they refer 
 the original customer 2 or the newly renumbered 
stomer 2?

The bottom line is this: once a key is 
assigned, it should never be reused, even if 
the entity to which it is assigned is subse-
quently deleted. Thus, as far as you are con-
cerned, there is no way to get your customers 
table to renumber from CustID  = 1. 

f course, there is a long and complicated way to do 
 but since used an autonumber in the first place, 
u do not care about the actual value of the key—
u just want it to be unique. In short, it makes abso-

lutely no 
custome

2.4.2.4

An input 
can type
tells Acce
each spa
consists 

1. The r
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icolon and zero at the end of this input mask 
rtant because, as the on-line help system 
t, an input mask value actually consists of 
ts (or “arguments”), each separated by a 
n:
tual template (e.g., 000\-0000 ),
e (0 or 1) that tells Access how to deal with 
 characters, and
aracter to use as a place holder (showing 
er how many characters to enter).

u use a literal character in an input mask, 
nd argument determines whether the literal 
imply displayed or displayed and stored in 

 as part of the data.

ple, if you use the input mask 000\-

 Access will not store the dash with the tele-
mber. Thus, although the input mask will 
isplay the number as “822-6109”, the num-
tually stored as “8226109”. By using the 
 Tables

ere are a large number of special symbols used 
r the input mask templates. Since the meaning of 
any of the symbols is not immediately obvious, 
ere is no requirement to remember the character 
des. Instead, simply place the cursor on the input 
ask property and press F1 to get help. In addition, 
e wizard can be used to provide a basic input mask 
ich can later be modified.

4.2.5 Input masks and literal values

 have the input mask automatically insert a char-
ter (such as a space or a dash) in a field, use a 
sh to indicate that the character following it is a lit-

al.

r example, to create an input mask for local tele-
one numbers (e.g., 822-6109), you would use the 

llowing template: 000\-0000;0  (the dash is a lit-
al value and appears automatically as the user 
ters the telephone number).

The sem
are impo
points ou
three par
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• the ac
• a valu

literal
• the ch
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the table
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0000;1 ,
phone nu
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in
Ac

pplication to the assignment
have the skills necessary to implement your 

e all the tables required for the assignment.
he autonumber data type (counter in version 
or your primary keys where appropriate.
ify field properties such as captions, input 
, and defaults where appropriate.

you create an input mask for ProductID , 
sure you understand the implications of 
ction 2.4.2.5.

e Default property of the OrderDate  field 
t the current date is automatically inserted 
e field when a new order is created (hint: 
e Date()  function in the on-line help sys-
 Tables

put mask 000\-0000;0 , however, you are telling 
cess to store the dash with the rest of the data.

If you use the wizard to create an input mask, 
it asks you a simple question about storing lit-
eral values (as shown in Figure 2.8) and fills 
in the second argument accordingly. How-
ever, if you create the input mask manually, 
you should be aware that by default, Access 
does not store literal values. In other words, 
the input mask 000\-0000  is identical to the 
input mask 000\-0000;1 . This has impor-
tant consequences if the field in question is 
subject to referential integrity constraints (the 
value “822-6109” is not the same as 
“8226109”).

2.5 A
You now 
tables.

• Creat
• Use t
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 Tables

• Do not forget to modify your Products  table (the 
data types, lengths, and field properties of 
imported tables normally need to be fine tuned)

• Populate (enter data into) your master tables. Do 
not populate your transaction tables.

For the purpose of the assignment, the term 
“transaction” tables refers to tables that con-
tain information about individual transactions 
(e.g., Orders , OrderDetails , Ship-

ments , ShipmentDetails ). “Master” 
tables, in contrast, are tables that either do 
not contain information about transactions 
(e.g., Customers ) or contain only summary 
or status information about transactions (e.g., 
BackOrders ).
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